Drive Order Creation - Issue Detected
Incident Report for DoorDash
Postmortem

On 11/13, the DoorDash Drive API was partially unavailable from 08:11 AM PT to 08:41 AM PT.
An internal change disrupted database health and impacted our ability to accept orders. Fulfillment was largely unaffected.
Reverting the change fixed the issue and made the DoorDash Drive API available. Since then, we have introduced additional levers to prevent these types of issues.

Posted Nov 13, 2024 - 11:16 PST

Resolved
The issue with Drive API is now confirmed to be resolved.

No further updates.
Posted Nov 13, 2024 - 09:36 PST
Monitoring
The issue is fixed and we are seeing recovery. We will continue to monitor the API health
Posted Nov 13, 2024 - 09:09 PST
Identified
Team has identified the issue.
Right now we are seeing partial error rates on V1 across all APIs.
Posted Nov 13, 2024 - 08:45 PST
Investigating
We have detected an issue with Order Creation. We are actively investigating.
V1 order creation seems to be impacted. V2 seems healthy

Next update in 15 minutes.
Posted Nov 13, 2024 - 08:35 PST
This incident affected: Drive (Drive API).