Drive APIs Issue Detected
Incident Report for DoorDash
Postmortem

On 4/24/2024 between 7:10 and 7:50PM PST we experienced an issue with the Drive APIs and web surface areas resulting in degradation in Order Creation, Fulfillment, and Tracking. This issue was caused by an issue at our traffic layer, which has since been resolved. The system remains healthy since 7:50 PM and we are taking appropriate actions to increase the resilience of our system to these types of events.

Posted Apr 24, 2024 - 21:28 PDT

Resolved
This incident has been resolved. No further updates
Posted Apr 24, 2024 - 21:26 PDT
Update
We are seeing the system working as intended, however are continuing to monitor as we continue to tweak to maintain stability. As of now, deliveries should be able to be created, fulfilled, and tracked as intended.
Posted Apr 24, 2024 - 20:34 PDT
Monitoring
We have identified the issue and are seeing early signs of recovery. Actively monitoring.
Posted Apr 24, 2024 - 19:51 PDT
Update
We are continuing to investigate this issue.
Posted Apr 24, 2024 - 19:40 PDT
Update
We are continuing to investigate this issue.
Posted Apr 24, 2024 - 19:37 PDT
Investigating
We are currently seeing a degradation in Drive Order Creation, Fulfillment, and Webhooks across APIs and Drive Form. The team is actively investigating and mitigating impact. Updates to follow
Posted Apr 24, 2024 - 19:31 PDT
This incident affected: Drive (Drive API, Drive Order Fulfillment, Drive Delivery Tracking Page) and Developer Portal, Merchant Portal.