On September 4th, beginning around 11:30 AM PT, an external vendor (Cloudflare) experienced an outage only in Ashburn that caused partial degradation of Drive public-facing APIs. Impact was only for the requests around that region. Cloudflare applied a fix on their end, and by approximately 12:02 PM PT error rates returned to baseline. DoorDash eng teams remain engaged, worked closely with Cloudflare to resolve the issue and closely monitored recovery to ensure services remain stable.
Posted Sep 10, 2025 - 12:55 PDT
Resolved
The issue with Order Creation is now confirmed to be resolved.
No further updates.
Posted Sep 09, 2025 - 12:31 PDT
Monitoring
The issue with Order Creation and Fulfillment is resolved but we will continue to monitor.
Next update in 15 minutes.
Posted Sep 09, 2025 - 12:13 PDT
Identified
We have identified an issue with Order Creation linked to one of our external vendors. The vendor is actively working on mitigation, and we are continuing to closely monitor the situation.
Next update in 15 minutes.
Posted Sep 09, 2025 - 12:07 PDT
Investigating
We have detected an issue with Order Creation. We are actively investigating.