Report Builder Outage on Mx Portal
Incident Report for DoorDash
Postmortem

From 2023-11-02 at 10:00 PM PT to 2023-11-03 1:00 PM PT, we had an outage for our report builder tooling which affected both scheduled reports and ad-hoc report generation tools. The cause of this was initially due to latency issues from Snowflake network requests. Failing report builder workflows were retrying an unlimited amount of times, due to improper configurations as well as uncapped defaults. This then caused our Snowflake warehouse overloaded and all requests were timing out, leading to this outage.The situation resolved as the Snowflake warehouse cleared the queue over time. From our end, we added explicit retry policies to avoid a similar issue occurring in the future.

Posted Dec 11, 2023 - 12:54 PST

Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 15:43 PDT
Update
This issue is mitigated now. We will follow up with a post-mortem.
Posted Nov 03, 2023 - 13:23 PDT
Investigating
We have an outage regarding Report Builder on Mx Portal. We are currently investigating the issue
Posted Nov 03, 2023 - 11:52 PDT
This incident affected: Merchant Portal.