DoorDash outage

Incident Report for DoorDash

Postmortem

On June 16, 2026, an unintended configuration change introduced invalid data into a critical authentication service. As a result the service was unable to process authentication requests correctly, resulting in widespread authentication failures.

This led to significant disruptions in order processing, reduced delivery volume, elevated cancellation rates, delayed deliveries, and increased customer remediation costs.

The incident was resolved by restoring a known-good configuration, increasing service capacity to accelerate recovery, and temporarily managing incoming traffic while systems stabilized.

To reduce the likelihood and impact of similar incidents in the future, we are implementing stronger configuration validation and schema enforcement, improving resilience and fallback behavior in critical services, and adding additional safeguards and rollout controls for changes to tier-0 infrastructure components.

Posted Jun 24, 2026 - 17:51 PDT

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 09:22 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2026 - 08:49 PDT

Update

We have implemented the fix and are starting to see some recovery
Posted Jun 16, 2026 - 08:35 PDT

Update

We have identified a fix and are working to implement
Posted Jun 16, 2026 - 08:03 PDT

Update

We are continuing to work on a fix for the issue
Posted Jun 16, 2026 - 07:33 PDT

Identified

The team identified the issue is continuing to look into a fix
Posted Jun 16, 2026 - 07:18 PDT

Update

We are continuing to investigate this issue.
Posted Jun 16, 2026 - 07:15 PDT

Investigating

We are aware of the issue and are currently investigating
Posted Jun 16, 2026 - 07:14 PDT
This incident affected: Drive (Drive API, Drive Order Fulfillment, Drive Delivery Tracking Page), DoorDash Commerce Platform (Mx Websites, Native Apps, Online Ordering (Storefront)), Developer Portal, Merchant Portal, Merchant Tablet, and Merchant - Marketplace (Orders, Menu Updates, Dasher Status Updates, Business Manager App, Catalog, Inventory).