Financial reports can be generated but not downloadable on Mx Portal
Incident Report for DoorDash
Resolved
We were able to identify the traffic blocking rule and the issue is resolved now. Financial reports are downloadable now.
Posted Mar 25, 2024 - 20:44 PDT
Investigating
We have partial outage on Mx Portal financial reports. These reports are able to be generated but not downloadable. We are currently investigating the issue
Posted Mar 25, 2024 - 19:59 PDT
This incident affected: Merchant Portal.